Ah. We switched from assigning an interrupt to the card status change interrupts (aka management interrupts) to using polling mode. Unfortunately, this hangs many recent sony vaio systems. You will need to assign an irq to the pcic device. I think it is 11, but I'm not totally sure.
And indeed that resolved all problems with PCMCIA: Just put the following line in your kernel-config:
device pcic0 at isa? irq 11
and rebuild and install your kernel. This has been corrected in my kernel-config.
swap 250mb / 400mb /usr 1800mb /var 400mb
I wanted to keep my LILO menu in the MBR, so I decided to not overwrite it with the FreeBSD boot manager. My entries in /etc/lilo.conf look like this:
other = /dev/hda1 label = FreeBSD table = /dev/hda
As distribution set I've chosen "User", since I knew I would do a
cvsup for everything after the installation. Media was obviously my
pccard and I configured it for my private LAN behind my FreeBSD firewall.
That's why only "FTP Passive" for use behind a firewall worked.
After a while my system was ready to reboot. The installation procedure was
finished.
A few interesting things showed up at the boot process: USB and USB mass storage support already running (detected the Memorystick and of course my floppy drive), pcmcia card working, moused running - I was taken by surprise ;))
As written in the handbook I did a cvsup to -STABLE:
# mkdir /usr/local/etc/cvsup # cp /usr/share/examples/cvsup/stable-supfile /usr/local/etc/cvsup
I then edited the stable-supfile to achieve the following content:
# That's my local mirror, choose your nearest! *default host=cvsup.at.FreeBSD.org *default base=/usr/local/etc/cvsup *default prefix=/usr *default release=cvs tag=RELENG_4 *default delete use-rel-suffix src-all
And then did the cvsup and the built of "world" as written in the handbook:
# cvsup -g -L 2 /usr/local/etc/cvsup/stable-supfile # cd /usr/src # make buildworld
For the kernel built I took this kernel configuration file:
# cp ~mic/VAIO /usr/src/sys/i386/conf # cd /usr/src # make buildkernel KERNCONF=VAIO # make installkernel KERNCONF=VAIO # reboot
This is my rc.conf.
I booted into single user mode to do the rest of the upgrading procedure: At
the bootloader prompt (when it counts backwards from 10 to 0) I typed:
# boot -s
At the shell prompt the following:
# mount -a -t ufs # swapon -a # cd /usr/src # make installworld # mergemaster -i # reboot
On reboot I got the following dmesg.
Hm, should not be an issue here, but I write it anyway ;) First I generated a cvsup file for the ports tree in /usr/local/etc/cvsup:
# Again, this is my local mirror: *default host=cvsup.at.FreeBSD.org *default base=/usr/local/etc/cvsup *default prefix=/usr *default release=cvs tag=. *default delete use-rel-suffix ports-all
And then again up to the newest:
# cvsup -g -L 2 /usr/local/etc/cvsup/ports-supfile
And for every program I wanted to have on it did the following:
# cd /usr/ports # make search key=[name of program] # cd [path]/[to]/[program] # make install clean
Another way is to use the binary-fetching facility of the pkg_add tool:
# pkg_add -r [name of program]
This also checks for dependencies and tries to download the according packages
and installes them.
And then I just used the program. This might look similar for Debian Linux
users ...
First of all I copied /etc/defaults/make.conf to /etc/make.conf and uncommented the following:
CPUTYPE=i586 XFREE86_VERSION= 4
I installed X by using pkg_add -r Xfree86 and took my XF86Config-4 from Linux. I did some changes regarding the mouse devices. Here is my config file. Works like a charm. For TrueType support I took /usr/ports/x11-fonts/webfonts.
Sound is activated with the driver in the kernel. Use mixer to control the special settings.
It's so simple:
# cd /usr/ports/graphics/picturebook # make install clean
and you have it.
I followed the instructions from Tamotsu HATTORI.
I took the information from a japanese page which has diff for the linux version of the setbrightness and the vaiobat software. Applied and working ;)
There are some open issues I will try to get fixed. If anybody can give me some hints I would be pleased:
For any comments, recommendations, etc. please feel free to mail to Michael Dosser (mic at netbase.org) ...
$Id: index.html,v 1.2 2001/10/08 16:25:38 mic Exp $